Results 1 to 3 of 3

Thread: Equipment issues

  1. #1

    Equipment issues

    Hi, I bought a sword from the market place, I refined it, put it on my general, however every time I tried to upgrade the stars, the system would crash, go off line for a few seconds and then nothing. No upgrade happens. So I removed the sword to try and add stars without general, that didnít work because the sword vanished. Can you help plz, I have sent tickets, email and now this and still no answer from your customer service department, I m out of pocket as I purchased the sword with gems, tried multiple times to add stars so gold was used up also. Thank you

  2. #2
    I have the same issue with multiple items, most of them yellow. I can not progress my general properly and lost alot of currency.
    That happens after I tried to refine or upgrade a star on them. After that the Items is completely bugged/broken if it is NOT EQUIPED

    I am not able to:

    -Equip the item
    -Refine the item
    -Not even disassamble the item

    However, if I try to upgrade/refine the item while my general equipped it, it will also bug out and DISSAPPEAR once I uneqip it. It is nowhere in my inventory (yes I checked ALL tabs).

    I contacted support. No satisfying answer after I showed the video. I can not properly progress my general that way.

    Please fix it as soon as possible or find a way to compensate the players. It's very frustrating to spent huge amounts of currency/time into a yellow item just to have it brick....
    Last edited by TRF_; 08-13-2020 at 09:51 PM.

  3. #3
    Yep me to customer support do not care and you are unlikely to get it resolved. Just stop spending money. May make a difference

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts